It is currently Sun Jul 22, 2018 8:58 am

News News of Develop Once, Deploy Anywhere!

Site map of Develop Once, Deploy Anywhere! » Forum : Develop Once, Deploy Anywhere!

Enables developers to rapidly develop and package the the exactly same code and UI into Web, Native Desktop and Mobile Apps.

Panel user stretchable

I have a panel that contains a grid control. I want the user to be able to stretch the panel's width and height and the grid size should follow to fill the panel. Is there a property for this?
Read more : Panel user stretchable | Views : 1195 | Replies : 1 | Forum : CrossUI for Web Apps


templates not working on new project or new page

I can only seem to be able to create a blank project.
When I press on the different examples they don't work (no response).
I ran the debugger and see this:

index.js:1 Uncaught TypeError: Cannot read property 'name' of undefined
at Object._btn_apply_onclick (index.js:1)
at Object._ctl_gallery_onitemselected (index.js:1)
at Function.tryF (xui.js:9)
at fun (xui.js:9)
at Object.f (xui.js:9)
at onClick (index.js:1)
at f (xui.js:9)
at Function.Constructor (xui.js:9)
a
Read more : templates not working on new project or new page | Views : 1874 | Replies : 4 | Forum : Bug Report


CrossUI editor problem on reload

Hi.

I downloaded the latest crossUI 2.0 and am running on the Mac.
I'm having an issue where crossui runs well when I create a project. But if I exit crossUI and try to run it at a later time, I can load the project but the editor shows an empty screen with no components ... as if I started from scratch. When I look at the code, the code is correct and hasn't changed. ...
Read more : CrossUI editor problem on reload | Views : 2268 | Replies : 5 | Forum : Bug Report


Please explain Version 2.0 is NOT compatible with older vers

This is not a very clear comment

Please explain in detail. How do I migrate 'old' projects as a lot has changed.

Kevin

Update: I have found many of the changes in older files i.e. ._xxxxx code is now xui.xxxxx. _arr _each.

Are any of the templates or examples converted / rewritten in V2? I have added a few new pages and they look like V1.4 templates. Still have the screen dimensions at the bottom ...
Read more : Please explain Version 2.0 is NOT compatible with older vers | Views : 1846 | Replies : 3 | Forum : Bug Report


Move/Switch Workspace not saved

Changes to the workspace are not saved and need to be set on every restart of the program

Kevin
Read more : Move/Switch Workspace not saved | Views : 1591 | Replies : 2 | Forum : Bug Report


Licence Key not saved

Just installed V2, entered licence key and it was accepted.

Restart application and licence key has not been saved.

Tried entering it then editing a project, all saved. Still no licence key saved.

Windows10, 64 bit.

Kevin
Read more : Licence Key not saved | Views : 1464 | Replies : 2 | Forum : Bug Report




File Upload IAjax

I am unable to get IAjax to upload a file. I have tried regular Ajax with the File Combo box but that doesnt work for web application. I'm using the IAjax example from the Cookbook in chapter 4.5.2 page 109. I have over 20,000 lines of code so I'm only posting the sections that are specific to this issue. Basically, the "if(file)" condition is always false.

host.xui_ui_group1517.append(
xui.create("xui.UI.Label")
.setHost(host,"xui_ui_label_button_select_project")
.setLeft(20)
.setTop(130)
.setWidth(150)
.setZIndex(1002)
.setCaption("STEP 1: ...
Read more : File Upload IAjax | Views : 3371 | Replies : 7 | Forum : CrossUI for Web Apps


TreeView branch selected color

When you unfold a TreeView branch, the branch's background color changes to the "Selected" color (blue-gray). This over-rides any color coding that might have been programmatically applied to the branch. How can I make sure that the desired color stays applied when a tree branch is selected/unfolded.
Read more : TreeView branch selected color | Views : 1959 | Replies : 3 | Forum : CrossUI for Web Apps


New error in Ver 1.42

I'm getting these errors when my app starts in Ver 1.42, which I just installed:

Denying load of chrome-extension://ipdmoohkhghlcnojehgiodchpiphjbkh/logo256.png. Resources must be listed in the web_accessible_resources manifest key in order to be loaded by pages outside the extension.
chrome-extension://invalid/

Failed to load resource: net::ERR_FAILED


I don't recall seeing these errors in the previous version. Does this look like something I might be doing?
Read more : New error in Ver 1.42 | Views : 2241 | Replies : 3 | Forum : CrossUI for Web Apps


 

Login  •  Register


Statistics

Total posts 998 • Total topics 335 • Total members 38

cron