bug when creating new empty project

Develop and Deploy Native Apps for Windows, OS X, Linux, Unix ...

bug when creating new empty project

Postby tomy300 » Wed May 28, 2014 3:47 am

Hi

I have version 1.22

when creating new blank project, and try to run it in debug a got blank program

Image


here the debug.html

Code: Select all
<!DOCTYPE html>
<html>
    <head>
        <meta http-equiv="content-type" content="text/html; charset=utf-8" />
        <meta http-equiv="Content-Style-Type" content="text/css" />
        <meta name="keywords" content="GUI design,GUI builder,web UI,RAD,RIA,development tool,multi-platform,cross-platform,web app" />
        <meta name="description" content="Built by CrossUI RAD Tools - Develop Once,Deploy Anywhere, HTML5, CSS3 and JavaScript for all platforms" />
        <meta name="copyright" content="[email protected]" />
        <meta http-equiv="imagetoolbar" content="no" />
        <meta name="viewport" content="width=device-width, initial-scale=1.0">
    </script>
    <title>Built by CrossUI RAD Tools - Develop Once,Deploy Anywhere - HTML5, CSS3 and JavaScript for all platforms</title>
</head>
<body>
    <script type="text/javascript">
        var xuiPah=((window.localStorage&&localStorage.xuiPah)||"");
        document.write("<"+"link rel=\"stylesheet\" type=\"text/css\" href=\""+xuiPah+"runtime/xui/appearance/vista/theme.css\" />");
        document.write("<"+"script type=\"text/javascript\" src=\""+xuiPah+"runtime/xui/js/xui-debug.js\"><"+"/script>");
        document.write("<"+"script type=\"text/javascript\" src=\""+xuiPah+"runtime/xui/js/adv-debug.js\"><"+"/script>");
        document.write("<"+"img alt=\"Show Debug Window\" title=\"Show Debug Window\" src=\""+xuiPah+"runtime/debug.png\" width=\"32\" height=\"32\" style=\"position:absolute;top:0;right:0;cursor:pointer;z-index:9999\" onclick=\"if(typeof(require)=='function')require('nw.gui').Window.get().showDevTools()\" />");
        document.write("<"+"img id=\"loading\" alt=\"Loading...\" title=\"Loading...\" src=\""+xuiPah+"runtime/loading.gif\"/>");
    </script>
   

    <script type="text/javascript" src="App/js/index.js"></script>
    <script type="text/javascript">
        xui.launch('App', function(){xui('loading').remove();},'','vista');
        xui.win.onKeydown(function(p,e){
            var kb=xui.Event.getKey(e);
            if(kb.key.toLowerCase()=="d" && kb.ctrlKey){
                if(typeof(require)=="function")require('nw.gui').Window.get().showDevTools();
            }
            if(kb.key.toLowerCase()=="f5")
                window.location.reload(true);
        });
    </script>
</body>
</html>
tomy300
 
Posts: 70
Joined: Sat Nov 09, 2013 12:27 am

Re: bug when creating new empty project

Postby support » Wed May 28, 2014 4:00 am

We cant reproduct that.

Pleas use debug window to find out your problem.
support
 
Posts: 352
Joined: Sat Apr 27, 2013 9:22 am

Re: bug when creating new empty project

Postby tomy300 » Wed May 28, 2014 1:51 pm

Hi again

I uninstall crossui completely and download crossui install at http://www.crossui.com/Download/CrossUI-win32.exe
I create a new project and same thing blank program running. If I run old example program it's work only when creating new project.

the install path is c:\crossui instead of putting it in program file folder

I'm using windows 8.1
12 gig ram
2T HD.
tomy300
 
Posts: 70
Joined: Sat Nov 09, 2013 12:27 am

Re: bug when creating new empty project

Postby support » Wed May 28, 2014 2:43 pm

Find the following line in debug.html
javascript code
var xuiPah=((window.localStorage&&localStorage.xuiPah)||"");


modify to

javascript code
var xuiPah=((window.localStorage&&localStorage.xuiPath)||"");


And, we'll fix this bug in the next minor release.
support
 
Posts: 352
Joined: Sat Apr 27, 2013 9:22 am

Re: bug when creating new empty project

Postby tomy300 » Wed May 28, 2014 3:37 pm

var xuiPah=((window.localStorage&&localStorage.xuiPah)||""); not found in debug.html


but I found the problem, the runtime folder is not there when creating new project, if I copy the runtime to my app the prob is fix.
tomy300
 
Posts: 70
Joined: Sat Nov 09, 2013 12:27 am

Re: bug when creating new empty project

Postby support » Thu May 29, 2014 12:40 am

Did you read the red "NOTICE" in crossui-rad-desktop-1-22-is-released-t204.html?
support
 
Posts: 352
Joined: Sat Apr 27, 2013 9:22 am


Return to CrossUI for Desktop Apps

Who is online

Users browsing this forum: No registered users and 1 guest

cron