Question Debugger in CrossUI RAD Studio

Write your functional requirement here, be Specific please!

Question Debugger in CrossUI RAD Studio

Postby Sergei » Tue Aug 11, 2015 6:30 am

Hello.
I use CrossUI RAD Studio for Linux. Pressing the "Debug Application" on the toolbar, and then, in the window that opens press the button "Show Debug Window" get the error: "... The requested URL could not be retrieved. When a URL http://127.0.0.1:39471/devtools/devtools.html? The following error occurred. The connection to 127.0.0.1 failed ..... ". I think the port starts debugging (in this case 39471) must be open (iptables). But it is changing with each launch. How do I open it? Maybe somewhere in the settings, you can define a constant to the port?
Thanks.
Sergei
 
Posts: 31
Joined: Sat Apr 27, 2013 9:48 am

Re: Question Debugger in CrossUI RAD Studio

Postby support » Thu Aug 13, 2015 4:18 am

The port is created by NW JS, automatically.
support
 
Posts: 352
Joined: Sat Apr 27, 2013 9:22 am

Re: Question Debugger in CrossUI RAD Studio

Postby Sergei » Thu Aug 13, 2015 5:26 am

How, run the debugger under Debian, in fact created by port NW JS automatically, but Debian port that is closed?
Sergei
 
Posts: 31
Joined: Sat Apr 27, 2013 9:48 am

Re: Question Debugger in CrossUI RAD Studio

Postby support » Thu Aug 13, 2015 6:17 am

Please check your permissions issue

Also check your log file, to see why the port is not open
support
 
Posts: 352
Joined: Sat Apr 27, 2013 9:22 am

Re: Question Debugger in CrossUI RAD Studio

Postby Sergei » Thu Aug 13, 2015 7:42 am

The full error message is as follows:
-------------------------------------------------------------------------------------------------------------------------------------------------------------
ERROR
The requested URL could not be retrieved
Upon receiving the URL http://127.0.0.1:58728/devtools/devtools.html? the following error occurred
Connection to 127.0.0.1 failed
The system returned: (111) Connection refused
Remote host or network is unavailable. Retry the request later
The Your cache administrator: root.
-------------------------------------------------------------------------------------------------------------------------------------------------------------
As root it works normally. But working as root is not correct. I can assign user rights to a resource debugging, but I do not know where he is. You can tell me?
Sergei
 
Posts: 31
Joined: Sat Apr 27, 2013 9:48 am

Re: Question Debugger in CrossUI RAD Studio

Postby support » Thu Aug 13, 2015 8:39 am

I cant find the problem. try go to https://github.com/nwjs/nw.js/wiki.
support
 
Posts: 352
Joined: Sat Apr 27, 2013 9:22 am


Return to Functional Requirement

Who is online

Users browsing this forum: No registered users and 0 guests

cron